You should know enough vi to download and compile emacs.

--Steph Bailey